通达信机智资金流副图指标 主力强势进场 源码

机智资金流主图源码如下:



强弱:=EMA(COST(85),10);
分界:=EMA(COST(99),10);
DRAWBAND(强弱,RGB(80,00,20),分界,RGB(60,60,18));
UPSD:=强弱>REF(强弱,1) AND 分界>REF(分界,1);
TJRED:=IF(UPSD,分界,强弱);
DRAWBAND(TJRED,RGB(180,00,20),强弱,RGB(60,60,18));
DRAWKLINE(H,O,L,C);


{牛线优化,源码来自莫大的寻龙诀}
LT:=LLVBARS(L,60);
LTT:=BARSLAST(CURRBARSCOUNT=CONST(LT)+1);
HT:=FINDHIGHBARS(H,LT+1,60,1);
牛线:DRAWLINE(CURRBARSCOUNT=CONST(HT)+1,H,ISLASTBAR,REF(H,HT),0),COLORFF80FF,LINETHICK1;
牛线1:DRAWLINE(CURRBARSCOUNT=CONST(HT)+1,H,ISLASTBAR,REF(H,HT),0),COLORYELLOW,LINETHICK4,POINTDOT;


私募买点系统:=1;
上升趋势线:EMA(C,35),COLORRED,LINETHICK2;
NOTEXT_BLINE:IF(EMA(C,35)<REF(LLV(EMA(C,35),5),3),EMA(C,35),DRAWNULL),COLORBLUE,LINETHICK2;
{私募买点系统}
SMZT1:=C/REF(C,1)>1.098 AND C=H;
SMZT2:=COUNT(SMZT1,10)=1 AND SMZT1 AND C/O>1.03;
SMZT3:=BACKSET(ISLASTBAR,BARSLAST(SMZT2)+1);
SMZT4:=SMZT3>REF(SMZT3,1);
PDTJ:=私募买点系统=1 AND SMZT4 AND BARSLAST(SMZT4)<=120;
私募买点线: DRAWICON(PDTJ,L,34),COLORFF0080,LINETHICK2;



{板块排名}
TAX:=HORCALC(HYBLOCK,105,1,DRAWNULL);
TAA:=STRCAT(HYBLOCK,' 排名 :');
DRAWTEXT_FIX(ISLASTBAR,0.70,0.08,0,STRCAT(TAA,CON2STR(TAX,0)));



MA250:EMA(C,250),COLORBLUE,LINETHICK2;
MA2501:EMA(C,250),COLORWHITE,POINTDOT;







机智资金流副图源码如下:

{机智资金流}
{需要L2权限。没有权限}
超B:=L2_AMO(0,0)/10000.0;
大B:=L2_AMO(1,0)/10000.0;
中B:=L2_AMO(2,0)/10000.0;
小B:=L2_AMO(3,0)/10000.0;
超S:=L2_AMO(0,1)/10000.0;
大S:=L2_AMO(1,1)/10000.0;
中S:=L2_AMO(2,1)/10000.0;
小S:=L2_AMO(3,1)/10000.0;
中A:=(中B-中S);
小A:=(小B-小S);
STICKLINE(小A<0 ,0,小A,0.5,0),COLOR00FF00;
STICKLINE(小A>0 ,0,小A,0.5,0),COLOR00FF00;
STICKLINE(中A<0 ,0,中A,1.2,1),COLORFF0000;
STICKLINE(中A>0 ,0,中A,1.2,1),COLORFF0000;

超A:=(超B-超S);
大A:=(大B-大S);
STICKLINE(超A<0,0,超A,2.7,1),COLOR0000FF;
STICKLINE(超A>0,0,超A,2.7,1),COLOR0000FF;
STICKLINE(大A<0,0,大A,1.9,1),COLOR00FFFF;
STICKLINE(大A>0,0,大A,1.9,1),COLOR00FFFF;


未来函数检测结果如下:
该公式包含未来函数:BACKSET
该公式包含未来函数:COST
该公式包含未来函数:DHIGH
解密、定制、编写股票指标请联系QQ或微信同号:88652583
相关股票指标公式

打赏我们  | 联系我们  |  股票指标网  |  指标网   |  指标公式  |   加入收藏   |  设为主页

@2005-2023 粤ICP备2023063687号-2 股票指标网别名指标网仅为互联网文章,所有股票指标公式及文章仅供学习研究,并不构成投资建议,请勿以此为依据进行股票交易,由此引起的投资亏损与本站无关。股票指标网均来源互联网收集整理,如不慎侵犯了你的权益,请联系我们告知,我们将做删除处理
QQ:88652583 微信 88652583
sitemap站点地图