通达信股票计算器副图指标 计算反弹位置 突破目标位 源码

Q:=DRAWGBK(C>0, RGB(0,10,10),RGB(88,0,0),0,'11',0);
高点价:IF(HHV(H,N日内) AND N日内>0,HHV(H,N日内),高价),NODRAW,COLOR0000FF;
低点价:IF(LLV(H,N日内) AND N日内>0,LLV(L,N日内),低价),NODRAW,COLOR00FF00;
E4:=高点价;
C4:=低点价;
黄金1:=EXP(LN(E4)-LN(C4/E4)*1.382);
黄金2:=EXP(LN(E4)-LN(C4/E4)*1.618);
黄金3:=EXP(LN(E4)-LN(C4/E4)*2);
黄金4:=EXP(LN(E4)-LN(C4/E4)*2.382);
黄金21:=EXP(LN(E4)+LN(C4/E4)*0.236);
黄金22:=EXP(LN(E4)+LN(C4/E4)*0.382);
黄金23:=EXP(LN(E4)+LN(C4/E4)*0.5);
黄金24:=EXP(LN(E4)+LN(C4/E4)*0.618);
黄金31:=EXP(LN(E4)+LN(C4/E4)*1.382);
黄金32:=EXP(LN(E4)+LN(C4/E4)*1.618);
黄金33:=EXP(LN(E4)+LN(C4/E4)*2);
黄金34:=EXP(LN(E4)+LN(C4/E4)*2.382);
对数1:=POW(C4*C4*E4,1/3);
对数2:=POW(C4*E4,1/2);
对数3:=POW(C4*E4*E4,1/3);
突破1:=EXP((LN(E4)-LN(C4))/3+LN(E4));
突破2:=POW(POW(E4,3)/C4,1/2);
突破3:=EXP((LN(E4)-LN(C4))*2/3+LN(E4));
突破4:=EXP((LN(E4)-LN(C4))+LN(E4));
突破5:=EXP((LN(E4)-LN(C4))*4/3+LN(E4));
突破6:=EXP((LN(E4)-LN(C4))*5/3+LN(E4));
突破21:=EXP(LN(C4)-(LN(E4)-LN(C4))/3);
突破22:=EXP(LN(C4)-(LN(E4)-LN(C4))*1/2);
突破23:=EXP(LN(C4)-(LN(E4)-LN(C4))*2/3);
突破24:=EXP(LN(C4)-(LN(E4)-LN(C4)));
突破25:=EXP(LN(C4)-(LN(E4)-LN(C4))*4/3);
突破26:=EXP(LN(C4)-(LN(E4)-LN(C4))*5/3);
DRAWTEXT_FIX (1,0.1,0.01, 0,' ---- ☆ 一 号 计 算 器 ☆ ----'),COLORFFFF00;
DRAWTEXT_FIX (1,0 ,0.2,0,'上涨目标位一:'),COLOR0000FF;
DRAWNUMBER_FIX(1,0.07,0.2,0,黄金1),COLOR0000FF;
DRAWTEXT_FIX (1,0 ,0.4,0,'上涨目标位二:'),COLOR0000FF;
DRAWNUMBER_FIX(1,0.07,0.4,0,黄金2),COLOR0000FF;
DRAWTEXT_FIX (1,0 ,0.6,0,'上涨目标位三:'),COLOR0000FF;
DRAWNUMBER_FIX(1,0.07,0.6,0,黄金3),COLOR0000FF;
DRAWTEXT_FIX (1,0 ,0.8,0,'上涨目标位四:'),COLOR0000FF;
DRAWNUMBER_FIX(1,0.07,0.8,0,黄金4),COLOR0000FF;
DRAWTEXT_FIX (1,0.15 ,0.2,0,'回调反弹目标位一:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.24,0.2,0,黄金21),COLOR00FFFF;
DRAWTEXT_FIX (1,0.15 ,0.4,0,'回调反弹目标位二:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.24,0.4,0,黄金22),COLOR00FFFF;
DRAWTEXT_FIX (1,0.15 ,0.6,0,'回调反弹目标位三:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.24,0.6,0,黄金23),COLOR00FFFF;
DRAWTEXT_FIX (1,0.15 ,0.8,0,'回调反弹目标位四:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.24,0.8,0,黄金24),COLOR00FFFF;
DRAWTEXT_FIX (1,0.31 ,0.2,0,'下跌目标位一:'),COLOR00FF00;
DRAWNUMBER_FIX(1,0.38,0.2,0,黄金31),COLOR00FF00;
DRAWTEXT_FIX (1,0.31 ,0.4,0,'下跌目标位二:'),COLOR00FF00;
DRAWNUMBER_FIX(1,0.38,0.4,0,黄金32),COLOR00FF00;
DRAWTEXT_FIX (1,0.31 ,0.6,0,'下跌目标位三:'),COLOR00FF00;
DRAWNUMBER_FIX(1,0.38,0.6,0,黄金33),COLOR00FF00;
DRAWTEXT_FIX (1,0.31 ,0.8,0,'下跌目标位四:'),COLOR00FF00;
DRAWNUMBER_FIX(1,0.38,0.8,0,黄金34),COLOR00FF00;
DRAWTEXT_FIX (1,0.55,0.02, 0,' ---- ☆ 二 号 计 算 器 ☆ ----'),COLORFFFF00;
DRAWTEXT_FIX (1,0.46 ,0.2,0,'向上突破目标位一:'),COLOR0000FF;
DRAWNUMBER_FIX(1,0.54,0.2,0,突破1),COLOR0000FF;
DRAWTEXT_FIX (1,0.46 ,0.4,0,'向上突破目标位二:'),COLOR0000FF;
DRAWNUMBER_FIX(1,0.54,0.4,0,突破2),COLOR0000FF;
DRAWTEXT_FIX (1,0.46 ,0.6,0,'向上突破目标位三:'),COLOR0000FF;
DRAWNUMBER_FIX(1,0.54,0.6,0,突破3),COLOR0000FF;
DRAWTEXT_FIX (1,0.46 ,0.8,0,'向上突破目标位四:'),COLOR0000FF;
DRAWNUMBER_FIX(1,0.54,0.8,0,突破4),COLOR0000FF;
DRAWTEXT_FIX (1,0.61 ,0.26,0,'回调反弹目标位一:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.70,0.26,0,对数1),COLOR00FFFF;
DRAWTEXT_FIX (1,0.61 ,0.52,0,'回调反弹目标位二:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.70,0.52,0,对数2),COLOR00FFFF;
DRAWTEXT_FIX (1,0.61 ,0.76,0,'回调反弹目标位三:'),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.70,0.76,0,对数3),COLOR00FFFF;
DRAWTEXT_FIX (1,0.77 ,0.2,0,'向下突破目标位一:'),COLOR00FF00;
DRAWNUMBER_FIX(1,0.86,0.2,0,突破21),COLOR00FF00;
DRAWTEXT_FIX (1,0.77 ,0.4,0,'向下突破目标位二:'),COLOR00FF00;
DRAWNUMBER_FIX(1,0.86,0.4,0,突破22),COLOR00FF00;
DRAWTEXT_FIX (1,0.77 ,0.6,0,'向下突破目标位三:'),COLOR00FF00;
DRAWNUMBER_FIX(1,0.86,0.6,0,突破23),COLOR00FF00;
DRAWTEXT_FIX (1,0.77 ,0.8,0,'向下突破目标位四:'),COLOR00FF00;
DRAWNUMBER_FIX(1,0.86,0.8,0,突破24),COLOR00FF00;


来函数检测结果如下:
该公式没有未来函数

解密、定制、编写股票指标请联系QQ或微信同号:88652583
相关股票指标公式

打赏我们  | 联系我们  |  股票指标网  |  指标网   |  指标公式  |   加入收藏   |  设为主页

@2005-2023 粤ICP备2023063687号-2 股票指标网别名指标网仅为互联网文章,所有股票指标公式及文章仅供学习研究,并不构成投资建议,请勿以此为依据进行股票交易,由此引起的投资亏损与本站无关。股票指标网均来源互联网收集整理,如不慎侵犯了你的权益,请联系我们告知,我们将做删除处理
QQ:88652583 微信 88652583
sitemap站点地图