通达信乖金买卖副图指标 深化乖离指标 乖金+黄柱 源码附图

DRAWGBK(C>O,RGB(50,10,0),RGB(0,0,30),0,0,0);
RS1:=SMA(MAX(C-REF(C,1),0),7,1)/SMA(ABS(C-REF(C,1)),7,1)*100;
强弱买:FILTER(REF(RS1,1)< 20 AND RS1>REF(RS1,1),5)*2,COLORLIRED;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
乖深低:IF(乖离<=-8,-0.35,0),LINETHICK1,COLORGREEN;
乖浅低:IF(BETWEEN(BIAS,-2,-8),-0.2,0),LINETHICK1,COLORLIGRAY;
乖买:REF(乖浅低=-0.2,1)AND BIAS>REF(BIAS,1),COLORLIMAGENTA,NODRAW;
乖低金:CROSS(BIAS,乖离) AND REF(乖离< -4.5,1),COLORRED,NODRAW;
DRAWBAND(0,RGB(0,100,0),乖深低,0);
DRAWBAND(0,RGB(180,180,180),乖浅低,0);
STICKLINE(乖离<=-8,-0.2,0,1,0),COLORLIGREEN;
STICKLINE(乖浅低=-0.2,-0.1,0,1,0),COLORLIBLUE;
STICKLINE(乖买=1,-0.1,0,1,0),COLORLIMAGENTA;
STICKLINE(乖低金=1,-0.5,0,0,0),COLORRED;
更:(C-LLV(L,10))/(HHV(H,25)-LLV(L,10))*4,COLORMAGENTA;
好:EMA(更,3),COLORGREEN,DOTLINE;
A低:=更<=LLV(更,10),COLORWHITE,NODRAW;
买:REF(A低=1,1)AND 更>REF(更,1),COLORRED,NODRAW;
卖:IF(REF(更>=HHV(更,10),1)AND 更< REF(更,1),3.5,4),COLORLICYAN;
高:"DMI.PDI"(14,6)>33 AND "DMI.MDI"(14,6)< 10 AND "DMI.ADX"(14,6)>40 AND "DMI.ADXR"(14,6)>45,STICK,COLORBROWN,LINETHICK2;
险:((HHV(好,4)>3.6 OR 更>=3.8)AND 高=1)*0.5,STICK,COLORLICYAN,LINETHICK3;
调:IF(高=0 AND HHV(高,5)>0,-0.5,0),STICK,COLORGREEN,LINETHICK2;
可卖:=IF(险=1 AND H-C>C-L AND V>HHV(V,20)/2 AND C< O*1.01,-0.75,0),STICK,COLORCYAN,LINETHICK2;
出:IF(险=0 AND HHV(险,3)>0,-1,0),STICK,COLORCYAN,LINETHICK2;
遇警:=IF(可卖=-0.75,-0.75,IF(出< 0,-1,IF(险>0,1,IF(调< 0,-0.5,高)))),COLORSTICK;
KM:=REF(更<=LLV(更,10),1)AND 更>REF(更,1);
可买:IF(FILTER((C-L>H-C AND V>HHV(V,13)*0.4 OR KM=1)AND(乖深低=-0.35 OR 乖浅低=-0.2 OR 调=-0.5),1),0.3,0),STICK,COLORYELLOW,LINETHICK2;
关联:IF(可卖=-0.75,-0.75,IF(出< 0,-1,IF(险>0,1,IF(调< 0,-0.5,高)))),COLORRED,LINETHICK1;
STICKLINE(A低=1,1,1.1,1,0),COLORWHITE;
STICKLINE(买=1,1,1.1,1,0),COLORRED;
DRAWTEXT(乖低金=1,-0.5,' 乖金'),COLORRED;


来函数检测结果如下:
该公式没有未来函数

解密、定制、编写股票指标请联系QQ或微信同号:88652583
相关股票指标公式

打赏我们  | 联系我们  |  股票指标网  |  指标网   |  指标公式  |   加入收藏   |  设为主页

@2005-2023 粤ICP备2023063687号-2 股票指标网别名指标网仅为互联网文章,所有股票指标公式及文章仅供学习研究,并不构成投资建议,请勿以此为依据进行股票交易,由此引起的投资亏损与本站无关。股票指标网均来源互联网收集整理,如不慎侵犯了你的权益,请联系我们告知,我们将做删除处理
QQ:88652583 微信 88652583
sitemap站点地图