牛熊争霸主图和谐源码分享通达信公式 副图 源码附图

VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1:(EMA(VAR1,2)+EMA(VAR1,5)+EMA(VAR1,8)+EMA(VAR1,12))/4;
A2:EMA(A1,2);
A3:EMA(A2,2);
A4:EMA(A3,2);
多空线:EMA(CLOSE,24),COLOR3399FF,POINTDOT,LINETHICK6;
牛熊线:EMA(CLOSE,144),COLORFF00FF,POINTDOT,LINETHICK6;
MA1:EMA(C,55),COLOR3399FF;
MA2:EMA(C,65),COLORFF6600;
MA3:EMA(C,75),COLOR339933;
TJ:=IF(多空线>=REF(多空线,1),多空线,DRAWNULL);
TJ1:=IF(多空线<REF(多空线,1),多空线,DRAWNULL);
DRAWBAND(TJ,RGB(255,0,0),TJ,0);
DRAWBAND(TJ1,RGB(0,201,87),TJ1,0);
TJJ:=IF(牛熊线>REF(牛熊线,1),牛熊线,DRAWNULL),COLOR3366FF;
TJJ1:=IF(牛熊线<REF(牛熊线,1),牛熊线,DRAWNULL),COLOR006633;
DRAWBAND(TJJ,RGB(255,0,0),TJJ,0);
DRAWBAND(TJJ1,RGB(0,201,87),TJJ1,0);
DRAWBAND(A1,RGB(200,0,200),A4,RGB(34,139,34));
WW1:=FILTER(O<REF(L,1) AND C>O AND VOL>REF(V,1),13);
JH:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
SZ:=FILTER(CROSS(JH,35),13);
SX:=FILTER(CROSS(JH,30),7);
SQ:=FILTER(CROSS(71,JH),74);
SD:=FILTER(CROSS(80,JH),74);
AA:=IF(CAPITAL<1,SZ,SX);
BB:=IF(CAPITAL<1,SQ,SD);
CC:=REF(HHV(CLOSE,120),1);DD:=REF(LLV(CLOSE,120),1);
WW:=((100 * (CLOSE - DD)) / (CC - DD));EE:=AMOUNT;
FF:=(EMA(EE,5) / REF(EMA(EE,5),5));
霸占:=FILTER(((((((FF >= 2)) AND (WW < 35))) AND (BARSCOUNT(CLOSE) > 30)) OR (((((FF >= 2)) AND (WW < 100))) AND (BARSCOUNT(CLOSE) < 50))),90);
STICKLINE(C>REF(C,1),C,O,3.2,0),COLOR0000AA;
STICKLINE(C>REF(C,1),C,O,2.7,0),COLOR0000DD;
STICKLINE(C>REF(C,1),C,O,2.1,0),COLOR0022FF;
STICKLINE(C>REF(C,1),C,O,1.5,0),COLOR0066FF;
STICKLINE(C>REF(C,1),C,O,0.9,0),COLOR0099FF;
{STICKLINE(C>REF(C,1),C,O,0.3,0),COLOR00DDFF;}
STICKLINE(C<REF(C,1),C,O,3.2,0),COLOR990000;
STICKLINE(C<REF(C,1),C,O,2.7,0),COLORCC0000;
STICKLINE(C<REF(C,1),C,O,2.1,0),COLORFF4400;
STICKLINE(C<REF(C,1),C,O,1.5,0),COLORFF8800;
STICKLINE(C<REF(C,1),C,O,0.9,0),COLORFFCC00;
{STICKLINE(C<REF(C,1),C,O,0.3,0),COLORFFDD00;}
STICKLINE(C=REF(C,1),C,O,3.2,0),COLOR555555;
STICKLINE(C=REF(C,1),C,O,2.7,0),COLOR777777; 
STICKLINE(C=REF(C,1),C,O,2.1,0),COLOR999999;
STICKLINE(C=REF(C,1),C,O,1.5,0),COLORBBBBBB;
STICKLINE(C=REF(C,1),C,O,0.9,0),COLORDDDDDD;
{STICKLINE(C=REF(C,1),C,O,0.3,0),COLORFFFFFF;}
STICKLINE(霸占,C,O,3,2),COLOR000055;
STICKLINE(霸占,C,O,2.7,0),COLOR000077;
STICKLINE(霸占,C,O,2.1,0),COLOR000099;
STICKLINE(霸占,C,O,1.5,0),COLOR0000BB;
STICKLINE(霸占,C,O,0.9,0),COLOR0000DD;
{STICKLINE(霸占,C,O,0.3,0),COLOR0000FF;}
STICKLINE(WW1,CLOSE,OPEN,3.2,0),COLORBB00FF;
STICKLINE(WW1,CLOSE,OPEN,2.7,0),COLORFF33FF;
STICKLINE(WW1,CLOSE,OPEN,2.1,0), COLORFF66FF;
STICKLINE(WW1,CLOSE,OPEN,1.5,0),COLORFF99FF;
STICKLINE(WW1,CLOSE,OPEN,0.9,0),COLORFFBBFF;
{STICKLINE(WW1,CLOSE,OPEN,0.3,0),COLORFFDDFF;}
STICKLINE(AA,CLOSE,OPEN,3.2,0),COLOR0088FF;
STICKLINE(AA,CLOSE,OPEN,2.7,0),COLOR00AAFF;
STICKLINE(AA,CLOSE,OPEN,2.1,0),COLOR00CCFF;
STICKLINE(AA,CLOSE,OPEN,1.5,0),COLOR22FFFF;
STICKLINE(AA,CLOSE,OPEN,0.9,0),COLOR66FFFF;
{STICKLINE(AA,CLOSE,OPEN,0.3,0),COLOR99FFFF;}
STICKLINE(BB,CLOSE,OPEN,3.2,0),COLOR005500;
STICKLINE(BB,CLOSE,OPEN,2.7,0),COLOR007700;
STICKLINE(BB,CLOSE,OPEN,2.1,0),COLOR009900;
STICKLINE(BB,CLOSE,OPEN,1.5,0),COLOR00BB00;
STICKLINE(BB,CLOSE,OPEN,0.9,0),COLOR00DD00;
{STICKLINE(BB,CLOSE,OPEN,0.3,0),COLOR00FF00;};
 


未来函数检测结果如下:
该公式包含未来函数:CAPITAL
解密、定制、编写股票指标请联系QQ或微信同号:88652583
相关股票指标公式

打赏我们  | 联系我们  |  股票指标网  |  指标网   |  指标公式  |   加入收藏   |  设为主页

@2005-2023 粤ICP备2023063687号-2 股票指标网别名指标网仅为互联网文章,所有股票指标公式及文章仅供学习研究,并不构成投资建议,请勿以此为依据进行股票交易,由此引起的投资亏损与本站无关。股票指标网均来源互联网收集整理,如不慎侵犯了你的权益,请联系我们告知,我们将做删除处理
QQ:88652583 微信 88652583
sitemap站点地图