通达信AI底选股指标公式源码

J1:=-49.00;
显示资金条件:=vol>0 OR MINUTE!=0;
N日内:=89;
统计大阳天数:=1;
原DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
原DEA:=EMA(原DIF,9);
原macd:=(原DIF-原DEA)*2;
MACD金叉:=crOSS(原DIF,原DEA);
SJ:=PERIOD>1;
SHORT:=IF(SJ,12,18);
LONG:=IF(SJ,26,38);
MID:=IF(SJ,9,SQRT(SHORT*LONG)/2);
MACD基准:=100;
BG:=BARSCOUNT(CLOSE);
LL:=LLV(L,12);
HH:=HHV(H,12);
CCM:=CLOSE;
RSV:=(CCM-LL)/(1.001*HH-LL)*MACD基准;
RSV_JGL:=IF(BG>0,RSV,50);
KK:=SMA(RSV_JGL,4,1);
DD:=SMA(KK,3,1);
DIF%:=(EMA(RSV_JGL,LONG)-MACD基准/2);
DEA%:=EMA(DIF%,MID);
MACD%:=2*(DIF%-DEA%);
原RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*50-25;
K%:=SMA(原RSV,3,1);
D%:=SMA(SMA(原RSV,3,1),3,1);
J:=3*K%-2*D%;
kd金叉:=CROSS(K%,D%);
MACD顶:=CONST(HHV(MAX(DIF%,MACD%),BARSSINCE(C)));
MACD底:=IF(CONST(LLV(MIN(DIF%,MACD%),BARSCOUNT(C)))>=0,CONST(LLV(MIN(DIF%,MACD%),BARSCOUNT(C)))/2,CONST(LLV(MIN(DIF%,MACD%),BARSCOUNT(C))));
KD顶:=CONST(HHV(MAX(K%,D%),BARSSINCE(C)));
KD底:=IF(CONST(LLV(MIN(K%,D%),BARSCOUNT(C)))>=0,CONST(LLV(MIN(K%,D%),BARSCOUNT(C)))/2,CONST(LLV(MIN(K%,D%),BARSCOUNT(C))));
MCKD顶:=CONST(HHV(MAX((MACD顶+KD顶)/2,MACD%),BARSSINCE(C)));
MCKD底:=CONST(LLV(MIN((MACD底+KD底)/2,MACD%),BARSSINCE(C)));
JJD:=(HIGH+LOW+CLOSE)/3;
KVAR2:=REF(LOW,1);
KVAR3:=SMA(Abs(LOW-KVAR2),3,1)/SMA(MAX(LOW-KVAR2,0),3,1)*MCKD顶;
KVAR4:=EMA(KVAR3*10,3);
KVAR5:=LLV(LOW,13);
KVAR6:=HHV(KVAR4,13);
KVAR7:=EMA(IF(LOW<=KVAR5,(KVAR4+KVAR6*2)/2,0),3)/618;
KVAR8:=IF(IF(KVAR7>500,500,KVAR7)< ABS((MCKD顶-MCKD底)/2)*0.5,IF(KVAR7>500,500,KVAR7),ABS((MCKD顶-MCKD底)/2)*0.5);
XG:KVAR8>1 AND JJD>REF(JJD,1) AND REF(JJD,1)< REF(JJD,2);



来函数检测结果如下:
该公式没有未来函数

解密、定制、编写股票指标请联系QQ或微信同号:88652583
相关股票指标公式

打赏我们  | 联系我们  |  股票指标网  |  指标网   |  指标公式  |   加入收藏   |  设为主页

@2005-2023 粤ICP备2023063687号-2 股票指标网别名指标网仅为互联网文章,所有股票指标公式及文章仅供学习研究,并不构成投资建议,请勿以此为依据进行股票交易,由此引起的投资亏损与本站无关。股票指标网均来源互联网收集整理,如不慎侵犯了你的权益,请联系我们告知,我们将做删除处理
QQ:88652583 微信 88652583
sitemap站点地图