黄金三角划线黄金分割和三角划线通达信公式 主图 源码附图

 N:=10;P:=60;
趋势:ZIG(3,N);
↑:TROUGHBARS(3,N,1),COLOR0000FF,NODRAW;
↓:PEAKBARS(3,N,1),COLOR00FF00,NODRAW;
低:IF(↑=0,C,IF(↓<↑,TROUGH(3,N,1),REF(TROUGH(3,N,1),1))),COLOR00FFFF,NODRAW;
涨%:IF(↑<↓,(C/低-1)*100,REF((C/低-1)*100,↓)),COLOR0000FF,NODRAW;
高:IF(↓=0,C,IF(↑<↓,PEAK(3,N,1),REF(PEAK(3,N,1),1))),COLOR00FF00,NODRAW;
跌%:IF(↓<↑,(C/高-1)*100,REF((C/高-1)*100,↑)),COLORFFFF00,NODRAW;
{以下设置主图显示方式股票指标网 }
上:IF(趋势>REF(趋势,1),趋势,DRAWNULL),COLORRED,LINETHICK2;
下:IF(趋势<REF(趋势,1),趋势,DRAWNULL),COLORGREEN,LINETHICK2;
STICKLINE(↑=0,H*1.01,高,0,0),COLOR00FF00;
STICKLINE(↓=0,L*0.99,低,0,0),COLORFF00FF;
STICKLINE(BETWEEN(↑,0,7),低,低,3,1),COLOR00FFFF;
STICKLINE(BETWEEN(↓,0,7),高,高,3,1),COLOR00FF00;
STICKLINE(↑<↓,低,低,1,1),COLOR00FFFF;
STICKLINE(↓<↑,高,高,1,1),COLOR00FF00;
{以下设置黄金分割}
KJ:=高-低;
H1:高-KJ*0.191,COLOR00FFFF,NODRAW;
H2:高-KJ*0.382,COLOR0000FF,NODRAW;
H3:高-KJ*0.500,COLORFFFFFF,NODRAW;
H4:高-KJ*0.618,COLORFF00FF,NODRAW;
H5:高-KJ*0.809,COLOR00FF00,NODRAW;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<高,高,高,1,1),COLOR00FF00;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<H1,H1,H1,1,1),COLOR00FF00;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<H2,H2,H2,1,1),COLOR00FF00;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<H3,H3,H3,1,1),COLORFFFFFF;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<H4,H4,H4,1,1),COLOR00FF00;
STICKLINE(↑<↓ AND ↑>0 AND 趋势<H5,H5,H5,1,1),COLOR00FF00;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>H1,H1,H1,1,1),COLORFF00FF;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>H2,H2,H2,1,1),COLORFF00FF;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>H3,H3,H3,1,1),COLORFFFFFF;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>H4,H4,H4,1,1),COLORFF00FF;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>H5,H5,H5,1,1),COLORFF00FF;
STICKLINE(↓<↑ AND ↓>0 AND 趋势>低,低,低,1,1),COLORFF00FF;
ZHSJ:=IF(↓<↑,BACKSET(ISLASTBAR,↓),IF(↑<↓,BACKSET(ISLASTBAR,↑),0));
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),H1,'险'),COLOR00FFFF;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),H2,'高'),COLOR00FFFF;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),H3,'中'),COLOR00FF00;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),H4,'低'),COLOR00FFFF;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),H5,'支'),COLOR00FFFF;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),H1,'压'),COLORFFFFFF;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),H2,'高'),COLORFFFFFF;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),H3,'中'),COLOR0000FF;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),H4,'低'),COLORFFFFFF;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),H5,'弹'),COLORFFFFFF;
 


未来函数检测结果如下:
该公式包含未来函数:ZIG
该公式包含未来函数:PEAK
该公式包含未来函数:PEAKBARS
该公式包含未来函数:TROUGH
该公式包含未来函数:TROUGHBARS
该公式包含未来函数:BACKSET
解密、定制、编写股票指标请联系QQ或微信同号:88652583
相关股票指标公式

打赏我们  | 联系我们  |  股票指标网  |  指标网   |  指标公式  |   加入收藏   |  设为主页

@2005-2023 粤ICP备2023063687号-2 股票指标网别名指标网仅为互联网文章,所有股票指标公式及文章仅供学习研究,并不构成投资建议,请勿以此为依据进行股票交易,由此引起的投资亏损与本站无关。股票指标网均来源互联网收集整理,如不慎侵犯了你的权益,请联系我们告知,我们将做删除处理
QQ:88652583 微信 88652583
sitemap站点地图