通达信乖离通道副图指标 源码分享 附图

长期乖离:(CLOSE-MA(CLOSE,55))/MA(CLOSE,55)*100,COLORYELLOW,STICK,LINETHICK3;
IF(长期乖离<=0,长期乖离,0),COLORWHITE,STICK,LINETHICK3;
中期乖离:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100,COLORFF00FF,STICK,LINETHICK3;
IF(中期乖离<=0,中期乖离,0),COLORFFFF33,STICK,LINETHICK3;
短期乖离:(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100,COLORRED,STICK,LINETHICK3;
IF(短期乖离<=0,短期乖离,0),COLORBLUE,STICK,LINETHICK3;
VAR2:=REF(HIGH,1)*1.1;
{{昨日最高价*系数}
VAR3:=HIGH*1.1;
{当日最高价*系数}
VAR4:=(VAR3*VOL+VAR2*(CAPITAL-VOL))/CAPITAL;
VAR5:=REF(LOW,1)*0.9;
{昨日最低价*系数}
VAR6:=LOW*0.9;
{当日最低价*系数}
VAR7:=(VAR6*VOL+VAR5*(CAPITAL-VOL))/CAPITAL;
VAR8:=EMA(VAR7,30);
{求30日VAR7的移动平均}
VAR9:=EMA(VAR4,30);
{求30日VAR4的移动平均}
VAR10:=VAR9-2;
VAR11:=IF(CLOSE<=VAR8,VAR10,VAR9);
VAR12:=VAR11*2.5;
VAR13:=VAR10*2.5;
STICKLINE(VAR12=VAR13,中期乖离,0,2,1),COLOR408000;
通道上:MA(短期乖离,20)+1.618*STD(长期乖离,20),COLOR0099FF,LINETHICK2;
通道下:MA(短期乖离,20)-1.618*STD(长期乖离,20),COLOR0099FF,LINETHICK2;
轨迹:短期乖离,COLOR00FF00,LINETHICK2;


未来函数检测结果如下:
该公式包含未来函数:CAPITAL
解密、定制、编写股票指标请联系QQ或微信同号:88652583
相关股票指标公式

打赏我们  | 联系我们  |  股票指标网  |  指标网   |  指标公式  |   加入收藏   |  设为主页

@2005-2023 粤ICP备2023063687号-2 股票指标网别名指标网仅为互联网文章,所有股票指标公式及文章仅供学习研究,并不构成投资建议,请勿以此为依据进行股票交易,由此引起的投资亏损与本站无关。股票指标网均来源互联网收集整理,如不慎侵犯了你的权益,请联系我们告知,我们将做删除处理
QQ:88652583 微信 88652583
sitemap站点地图