通达信降龙诀副图指标 龙吟龙跃 源码分享 附图




X1:=C<=REF(C,1) AND C<=O;
X2:=C<=REF(C,1) AND C>=O;
X3:=X1>0 OR X2>0;
XT0:=BARSLAST(X3);
X4:=MAX(REF(C,XT0),REF(O,XT0));
X5:=REF(V,XT0);
YT:=XT0>0 AND C>X4 AND V>X4*1.1;YS:=IF(YT>0 AND REF(YT,1)=0,10,0);
YSJ:=YS>0;
XA1:=(CLOSE/REF(CLOSE,1)>1.098 OR C/O>1.098) AND V<HHV(V,21);
X0:=NOT(NAMELIKE('S') OR NAMELIKE('*S')) AND VOL>1;
XA2:=BARSLAST(XA1);
XA31:=(L>=REF(L,XA2) AND (L-REF(L,XA2))<=0.03);
XA32:=(L>=REF(C,XA2)*0.99 AND (L-REF(C,XA2))<=0.03) ;
XA33:=(0>=REF(C,XA2)*0.99 AND (0-REF(C,XA2))<=0.03);
XA3:=XA31 OR XA32 OR XA33;
龙吟:YSJ AND C>O AND C>REF(C,1) AND XA3 AND (XA2<21 OR COUNT(REF(XA2,1),21)>=1) AND X0,COLORYELLOW;
YB:=(C-REF(C,1))*100/REF(C,1)>=9.9 AND L=H;
XA4:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
XA5:=MA(XA4,5);
XA6:=PLOYLINE(CROSS(XA4,XA5),XA5);
XA7:=PLOYLINE(CROSS(XA5,XA4),XA4);
XA8:=COUNT(CROSS(XA4,XA5),XA6<REF(XA6,5) AND XA7>REF(XA7,5));
XA9:=CROSS(EMA(C,3),EMA(C,21));
XA10:=CROSS(MA(C,3),MA(C,21));
XA11:=((MAX(C,O)-MIN(C,O))/MIN(C,O))*100;
XA12:=(CLOSE/REF(CLOSE,1)<=0.96 OR CLOSE/OPEN<=0.96) AND (V/HHV(V,20)<=0.618 OR VOL/REF(VOL,1)<=0.5 OR VOL<HHV(VOL,5));
XA13:=(CLOSE/REF(CLOSE,1)>=1.04 OR CLOSE/OPEN>=1.04) AND (V/HHV(V,20)<=0.618 OR VOL/REF(VOL,1)<=0.5 OR VOL<HHV(VOL,5))
AND C>REF(C,1) AND HIGH>LOW;
XA14:=O>REF(C,1) AND C>REF(C,1) AND H>(H,1);
XA15:=(REF(C<REF(C,1) AND V/REF(V,1)<0.67,2) OR REF(XA12,2) OR REF(XA13,2)) AND REF(XA11<3,1) AND REF(V,1)<REF(V,2) AND XA14;
XA16:=O>REF(CLOSE,1) AND CLOSE>OPEN AND CLOSE>REF(O,1);
XA17:=(REF(XA12,1) AND XA16 AND XA13) OR XA15;
XA18:=(CROSS(C,MA(C,5)) AND CROSS(C,MA(C,13)) AND CROSS(C,MA(C,21)) OR CROSS(C,MA(C,34)))
AND MA(C,5)>REF(MA(C,5),1);
XA19:=MA(C,5)>REF(MA(C,5),1) AND MA(C,5)>MA(C,10) AND MA(C,10)>=MA(C,20);
XA20:=XA18 AND 龙吟 AND NOT(YB) AND (XA8 OR XA10 OR XA9 OR CROSS(C,MA(C,20)));
XA21:=龙吟 AND (V/REF(V,1)>1.5 OR REF(V,1)/REF(V,2)<0.67) AND (XA8 OR XA10 OR XA9 OR CROSS(C,MA(C,20))) AND NOT(O/REF(C,1)>1.06)
AND NOT(YB) AND X0,COLORMAGENTA;
XA22:=C>O AND C>REF(C,1) {AND V>REF(V,1)} AND XA17 AND (COUNT(龙吟,8)=1 OR XA18) AND NOT(YB)
AND (XA8 OR XA10 OR XA9 OR CROSS(C,MA(C,20))) AND X0,COLORGREEN;
龙跃:(XA20 OR XA21 OR XA22),COLORCYAN;


来函数检测结果如下:
该公式没有未来函数

解密、定制、编写股票指标请联系QQ或微信同号:88652583
相关股票指标公式

打赏我们  | 联系我们  |  股票指标网  |  指标网   |  指标公式  |   加入收藏   |  设为主页

@2005-2023 粤ICP备2023063687号-2 股票指标网别名指标网仅为互联网文章,所有股票指标公式及文章仅供学习研究,并不构成投资建议,请勿以此为依据进行股票交易,由此引起的投资亏损与本站无关。股票指标网均来源互联网收集整理,如不慎侵犯了你的权益,请联系我们告知,我们将做删除处理
QQ:88652583 微信 88652583
sitemap站点地图